icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.liuzongfeng.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

乐彩客彩票 www.ou99.com-福彩3d实用的书| www.586404.com-充值送彩金38| www.713059.com-吉林快三案-| www.836658.com-蓝月亮彩票-| www.963442.com-邳州彩礼新规定| www.g60.cc-体彩排列三定胆最准| www.27nr.com-彩票的投注技巧| www.82425.com-福客来彩票官网| www.055269.com-彩36官方彩票网| www.780626.com-彩虹宝宝英文版| www.945501.com-福彩头像图片| PK彩票www.8499t.com| www.0324.loan-826网络彩票论坛| www.282866.com-彩票33苹果版| www.372944.com-c16彩票-| www.499698.com-韩国足球彩票| www.427910.com-鸿彩网充值-| www.727575.com-合买中心一鑫鼎彩票| www.704426.com-彩票336网页版| www.bn13.com-易彩娱乐app下载| www.004626.com-竞彩组合漏洞| www.06av.com-真彩48色彩铅色卡| www.38in.com-彩铅脸部上色技巧| www.022388.com-乐8时时彩-| www.111120.com-3d新彩网字谜总汇| www.334327.com-快三多长时间一期| www.4252.net-彩7下载-| www.21297.cc-好的福利彩票店收入| www.727.org-时时彩开奖计划| www.950735.com-彩票足球软件| www.am05.cc-购彩大厅360彩票| www.i36.top-福彩刮刮乐就是坑啊| www.94ro.com-易彩国际马来西亚| www.07422.com-全民娱乐彩票官网| www.062500.com-9万彩票官网平台| www.111927.com-彩票十大网站| www.99186.cc-腾讯分分彩彩金| 彩客网www.963063.com| www.531678.com-彩搜网专业彩搜网| www.645199.com-七乐彩秘籍-| www.757117.com-创富彩票平台下载| www.878996.cc-中金彩app-| www.987323.com-福彩大赢家走势图| www.yu82.com-2圆神圣彩票| www.80xw.com-天天时时彩手机版3| www.5575.win-极限赛车彩票| www.444241.com-苹果版彩38-| www.570866.com-福彩3d试机号快报| www.475781.com-网络彩票没被黑过| www.608188.cc-必发彩票信誉第一| www.717916.com-彩虹寓意-| www.789738.com-微彩会彩票下载安装| www.874352.com-彩票三地-| www.958943.com-体彩胜负彩预告| 大赢家彩票www.590981.com| www.875016.com-太原彩票店转让信息| www.050107.com-鎏三十载公益福彩| www.932035.com-下载够力七星彩票| www.93928.com-足彩最大推荐平台| www.56xr.com-营业中体彩店转让| www.3553.cn-免费领取38彩金| www.30027.com-体彩折线走势图| www.445332.com-专业玩彩票开| www.469699.com-快乐5分彩走势图| www.093365.com-彩色混凝土的颜色| www.801889.com-彩票老头-| www.879372.com-人人中彩票哪里出票| www.950340.com-乐彩网怎么打不开| www.994951.com-好好彩平特一肖| www.qy6.cc-惠民彩票官方网站| www.mv86.com-快三爱彩乐-| www.074118.com-体彩排双胆预测| www.585038.com-二四好彩网-| www.330124.com-福彩单双大小玩法| www.467511.com-七乐彩红球杀1个号| www.660057.com-七星彩大公鸡梦册| www.763528.com-明鑫娱乐彩票| www.868891.com-七星彩最新图规| www.961340.com-竞彩猫电脑版官网| www.el20.com-彩票代打-| www.i95.me-一分快三全天预测| www.895400.com-中体华彩合法吗| www.692626.com-中国移动积分兑彩票| www.778212.com-福彩图迷汇总八| www.890234.com-大盛游戏彩票网站| www.960264.com-淘彩下载-| 网易彩票www.177348.com| www.hf35.com-体彩大乐透专家推荐| www.82gb.com-中国移动和彩印| www.826213.com-金沙环球购彩| www.919857.com-模拟彩票打印系统| www.983667.com-足彩加app下载| www.bc31.cc-快三官网开奖| www.353727.com-带人玩彩票是真的吗| www.444255.com-福彩三地和值走势期| www.539438.com-彩创天地手工陶艺| www.652302.com-彩客手机版旧版| www.710102.com-怎样套彩-| www.818742.com-时时彩十码-| www.896121.com-国彩网是正规的吗| www.970356.com-优乐彩下载| www.cv6.com-马云买了26年彩票| www.950276.com-3d合值振幅彩宝贝| 大赢家彩票平台www.103658.com| www.635821.com-七彩娱乐东川麻将| www.031491.com-澳客彩票苹果版下载| www.111116.com-长乐坊彩票能提款吗| www.206337.com-重庆快三走势图| www.63851.cc-汇丰彩票app下载| www.008285.com-七乐彩开奖在哪个台| www.760133.com-买彩票提成多少| www.019482.com-体彩跟福彩哪个更假| www.pw31.com-彩票什么叫龙| www.514885.com-买七星彩的网站| www.780827.com-彩虹吉他谱txt| www.938386.com-非法体彩-| 五彩堂www.898418.com| www.789372.com-竞彩优化器-| www.863375.com-彩票选号必中神器| www.932773.com-乐彩网-官方网站| www.996388.com-足彩北单胜负彩| www.dt48.com-彩票ios-| www.602358.com-彩票中奖结果双色球| www.1aa.cc-彩乐坊快三-| www.635349.com-七彩假期旅行社| www.319897.com-体彩各省中奖情况| www.394360.com-足彩复式经济投注| www.65365.cc-西宁体彩兑奖地址| www.590203.com-竞彩14场分析| www.665468.com-七乐彩机选器| www.206416.com-利彩app-| www.179750.com-湖北快三一定牛推荐| www.507150.com-唐三彩彩票-| www.565846.com-12.cc彩票-| www.630253.com-彩吧彩报图谜第三版| www.736844.com-银彩通不能用了| www.411110.com-年2鱼玩彩猜一字| www.027640.com-体彩排列五走逝图| www.996067.com-北京pk彩票-| www.ef37.com-彩票登陆-| www.yn34.com-体彩排三开奖时间| www.83bb.com-移动彩云注销| www.2060.me-彩票平台被骗| www.kq88.com-福彩农场-| www.55fu.com-重庆体彩怎么申请| www.2470.vip-大乐透彩迷天地| www.81300.com-统一彩票-| www.040747.com-广东快三平台| www.544183.com-鼓励买彩票的广告| www.640094.com-奥克足球竞彩网| www.740977.com-28彩票娱乐-| www.826478.com-苏宁彩票幸运28| www.913873.com-哪个彩票平台最可靠| 快彩在线www.2632o.com| www.088976.com-速彩-| www.145313.com-足彩14场奖金| www.el03.com-彩票代打兼职平台| 13e彩票www.815870.com| www.23473.com-瑞彩网-| www.92261.cc-易彩智能投注软件| www.44yz.com-分分彩选号软件| www.408.biz-彩票中奖51亿| www.57yo.com-厦门市体育彩票| www.536235.com-时时彩连中二十把|